2015-08-17 101 views
6

我的Android Studio安裝出現問題,每次我在設計視圖中向佈局添加小部件時都會崩潰。所以我下載了剛好是預覽版的最新版本。這固定了崩潰。這不是一個安裝程序,但它只是所有的文件壓縮。所以我刪除了舊的Android Studio版本,並將其替換爲此預覽版本。AssertionError:build-tools-23.0.0不匹配build-tools-23.0.0-preview

現在每次我打開任意時間遇到了以下錯誤: AssertionError: build-tools-23.0.0 doesn't match build-tools-23.0.0-preview 此外,由於不再承認我的電話時,我嘗試建立我的應用程序,所以我不能測試它。我不確定這兩個問題是否有關係。

+0

您不再需要使用預覽構建工具。只需在build.gradle文件中使用buildToolsVersion「23」 – axay

+0

我只是試着將'buildToolsVersion「23.0.0 rc2」'更改爲'buildToolsVersion「23」'並且'AssertionError'仍然存在,並且它會創建一個新的gradle錯誤'找不到構建工具版本23.0.0' –

+0

谷歌幾小時前發佈v23。你有更新嗎? – axay

回答

0

我遇到的EXZACT同樣的問題,解決它通過以下方式:

轉到文件>項目結構>選擇模塊> BuildToolsVersion

選擇Build版本23.0.1(或什麼都版本是最新當時你正在閱讀)。然後確保您的構建工具版本與您編譯的Sdk版本相同。