我有一個類來分析一個字符串,如果字符串不是空字符串,它會根據子類的類型使用該對象創建一個新的String或new Date。如果字符串爲空或空,它將返回一個空字符串。目前我稱之爲類轉換器,但我覺得這個名字是誤導性的,有沒有更好的名字,任何人都可以想到這個類正在做什麼?我想直觀的東西讓我的代碼更具可讀性。謝謝。需要幫助命名類
public abstract class Converter {
Object returnObject;
public Converter() {
}
public Object convert(String value)
{
if(!this.isEmpty(value))
{
this.setReturnObject(value);
}else
{
this.returnObject = "";
}
return this.getReturnObject();
}
protected boolean isEmpty(String value)
{
return (value != null && value.equalsIgnoreCase(""));
}
protected abstract void setReturnObject(String value);
protected Object getReturnObject(){
return this.returnObject;
}
}
public class NumberConverter extends Converter {
public NumberConverter() {
}
protected void setReturnObject(String value) {
this.returnObject = new Number(Integer.parseInt(value));
}
}
我認爲它屬於這裏:http://english.stackexchange.com/ :) – MByD
我想我是在正確的論壇。命名是生成可讀代碼的一個重要組成部分,至少根據鮑勃叔叔的書籍Clean Coder和Clean Code –