2016-12-18 65 views
0

的我tyring安裝cohttp與OPAM,我得到關於modular-implicitsOPAM安裝cohttp失敗,因爲camlp4

這裏的錯誤是camlp4堆棧跟蹤

[email protected]:~$ opam install camlp4 
The following actions will be performed: 
    ∗ install camlp4 4.02.0-1modular-implicits 

=-=- Gathering sources =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-= 
[camlp4] Archive in cache 

=-=- Processing actions -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-= 
[ERROR] The compilation of camlp4 failed at "make all". 
Processing 1/1: [camlp4: rm] 
#=== ERROR while installing camlp4.4.02.0-1modular-implicits ==================# 
# opam-version 1.2.2 
# os   linux 
# command  make all 
# path   /home/chris/.opam/core/build/camlp4.4.02.0-1modular-implicits 
# compiler  system (4.02.3) 
# exit-code 2 
# env-file  /home/chris/.opam/core/build/camlp4.4.02.0-1modular-implicits/camlp4-12430-e7966f.env 
# stdout-file /home/chris/.opam/core/build/camlp4.4.02.0-1modular-implicits/camlp4-12430-e7966f.out 
# stderr-file /home/chris/.opam/core/build/camlp4.4.02.0-1modular-implicits/camlp4-12430-e7966f.err 
### stdout ### 
# [...] 
# cp /usr/lib/ocaml/compiler-libs/parsetree.cmi camlp4/import/parsetree.cmi 
# cp /usr/lib/ocaml/compiler-libs/outcometree.cmi camlp4/import/outcometree.cmi 
# cp /usr/lib/ocaml/compiler-libs/oprint.cmi camlp4/import/oprint.cmi 
# cp /usr/lib/ocaml/compiler-libs/toploop.cmi camlp4/import/toploop.cmi 
# /usr/bin/ocamlc.opt -c -g -w Z -I camlp4/import -warn-error A-3 -I camlp4/config -I camlp4 -o camlp4/config/Camlp4_config.cmi camlp4/config/Camlp4_config.mli 
# /usr/bin/ocamlc.opt -c -g -w a -I camlp4/import -warn-error A-3 -I camlp4/config -I camlp4/boot -o camlp4/boot/Camlp4.cmo camlp4/boot/Camlp4.ml 
# + /usr/bin/ocamlc.opt -c -g -w a -I camlp4/import -warn-error A-3 -I camlp4/config -I camlp4/boot -o camlp4/boot/Camlp4.cmo camlp4/boot/Camlp4.ml 
# File "camlp4/boot/Camlp4.ml", line 14607, characters 36-58: 
# Error: Unbound type constructor Asttypes.implicit_flag 
# Command exited with code 2. 
### stderr ### 
# + echo camlp4/Camlp4.cmo camlp4/Camlp4Top.cmo camlp4/camlp4prof.byte camlp4/mkcamlp4.byte camlp4/camlp4.byte camlp4/camlp4fulllib.cma camlp4/camlp4boot.byte camlp4/camlp4boot.cma camlp4/camlp4r.byte camlp4/camlp4r.cma camlp4/camlp4rf.byte camlp4/camlp4rf.cma camlp4/camlp4o.byte camlp4/camlp4o.cma camlp4/camlp4of.byte camlp4/camlp4of.cma camlp4/camlp4oof.byte camlp4/camlp4oof.cma camlp4/camlp4orf.byte camlp4/camlp4orf.cma camlp4/Camlp4Parsers/Camlp4AstLoader.cmo camlp4/Camlp4Parsers/Camlp4DebugParser.cmo camlp4/Camlp4Parsers/Camlp4GrammarParser.cmo camlp4/Camlp4Parsers/Camlp4ListComprehension.cmo camlp4/Camlp4Parsers/Camlp4MacroParser.cmo camlp4/Camlp4Parsers/Camlp4OCamlOriginalQuotationExpander.cmo camlp4/Camlp4Parsers/Camlp4OCamlParser.cmo camlp4/Camlp4Parsers/Camlp4OCamlParserParser.cmo camlp4/Camlp4Parsers/Camlp4OCamlReloadedParser.cmo camlp4/Camlp4Parsers/Camlp4OCamlRevisedParser.cmo camlp4/Camlp4Parsers/Camlp4OCamlRevisedParserParser.cmo camlp4/Camlp4Parsers/Camlp4OCamlRevisedQuotationExpander.cmo camlp4/Camlp4Parsers/Camlp4QuotationCommon.cmo camlp4/Camlp4Parsers/Camlp4QuotationExpander.cmo camlp4/Camlp4Printers/Camlp4AstDumper.cmo camlp4/Camlp4Printers/Camlp4AutoPrinter.cmo camlp4/Camlp4Printers/Camlp4NullDumper.cmo camlp4/Camlp4Printers/Camlp4OCamlAstDumper.cmo camlp4/Camlp4Printers/Camlp4OCamlPrinter.cmo camlp4/Camlp4Printers/Camlp4OCamlRevisedPrinter.cmo camlp4/Camlp4Filters/Camlp4AstLifter.cmo camlp4/Camlp4Filters/Camlp4ExceptionTracer.cmo camlp4/Camlp4Filters/Camlp4FoldGenerator.cmo camlp4/Camlp4Filters/Camlp4LocationStripper.cmo camlp4/Camlp4Filters/Camlp4MapGenerator.cmo camlp4/Camlp4Filters/Camlp4MetaGenerator.cmo camlp4/Camlp4Filters/Camlp4Profiler.cmo camlp4/Camlp4Filters/Camlp4TrashRemover.cmo 
# make: *** [byte] Error 10 



=-=- Error report -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-= 
The following actions failed 
    ∗ install camlp4 4.02.0-1modular-implicits 
No changes have been performed 

這是在Ubuntu 14.04發生,我該如何解決這個正在發生的奇怪錯誤?

編輯:相關信息

[email protected]:~$ ocaml -version 
The OCaml toplevel, version 4.02.3 
[email protected]:~$ opam --version 
1.2.2 

回答

2

我會建議走OPAM( opam switch 4.02.3 )安裝在您的ocaml的編譯器。它看起來你的ocaml位於你的系統中。

顯然,這是opam數據庫的舊版本:opam update可能會解決它。

+0

我試着運行'opam switch 4.02.3',並且我在日誌中以相同的錯誤 –

+0

結束了,還是有引用ocaml安裝在/ usr/bin? ...否則,你嘗試opam更新? –

+0

您對'opam update'的評論有訣竅。如果您想將其添加到您的帖子中,那對下一個出現的人來說會很棒。 –