我有兩個功能在我的角度項目,一個是aceitaProposta
做這個:減少JavaScript代碼
aceitaProposta() {
this.aceita();
// some other code
}
,我有recusaProposta
:
recusaProposta() {
this.recusa();
// some other code
}
現在,this.recusa
和this.aceita
之間的唯一區別是第一個遞增一個屬性,第二個遞減它。我想知道是否有一種方法可以將這兩個函數轉換爲一個函數,僅使用if
之類的函數來識別其遞減或遞增。這樣,我會在aceitaProposta
和recusaProposta
中調用相同的函數。例如:
aceitaProposta() {
this.incrementDecrement();
// some other code
}
recusaProposta() {
this.incrementDecrement();
// some other code
}
當然,您可以將一個布爾值傳遞給該函數以指示該值是應該遞增還是遞減。 –
'this.add(1)','this.add(-1)'。 – Bergi
爲什麼你需要一個功能來做兩件不同的事情?最好將它們分開,而不是將控制流添加到應該是簡單的東西上。 –