我有以下功能:如何讓此代碼更優雅?
private def solveError(hostIp: String, command: String) = {
commandSlave(hostIp, "STOP SLAVE") match {
case Success(x) => commandSlave(hostIp, command) match {
case Success(y) => commandSlave(hostIp, "START SLAVE") match {
case Success(z) => Success(z)
case Failure(ex) => Failure(ex)
}
case Failure(ex) => Failure(ex)
}
case Failure(ex) => Failure(ex)
}
}
我認爲必須有寫這個功能更優雅的方式,但我不知道怎麼樣。使用嵌套匹配的情況對我來說並不合適,但我是Scala的新手,我不知道是否有更好的方法。任何幫助深表感謝。
可能更適合於代碼審查 – Hypaethral