2016-09-14 209 views
0

我已經安裝在我的電腦的Windows 7。我正在嘗試使用visual studio community 2015和xamarin開發android應用程序。 但我在部署時出現錯誤。 我想知道使用的Visual Studio 2015年的社區和開發Android aaplication系統要求。系統要求

錯誤,同時部署是如下: -

Mono.AndroidTools.InstallFailedException: Failure [INSTALL_FAILED_NO_MATCHING_ABIS] 
1> at Mono.AndroidTools.Internal.AdbOutputParsing.CheckInstallSuccess(String output, String packageName) 
1> at Mono.AndroidTools.AndroidDevice.<>c__DisplayClass90_0.b__0(Task`1 t) 
+0

請儘快給我建議.... – rahulp

回答

0

這個錯誤意味着你要在設備上安裝它使用一個架構未通過的部分支持的應用應用。

如果您使用的是非常模糊的設備,Xamarin捆綁幾個本地庫在每一個Xamarin.Android應用程序,它可能是其中之一是與設備不兼容。

另一種可能是,你正在使用的使用「英特爾」架構的仿真器。這可能與爲使用「ARM」架構的設備設計的庫不兼容,這些架構最常見於手機和平板電腦。如果是這種情況,請嘗試使用其他模擬器。