2009-10-22 194 views

回答

8

我不明白爲什麼沒有,有就是Python 3的正常工作的version available,唯一的選擇,如果你真的需要的Qt將PySide,這遠不是與Python 3

兼容其他的GUI替代品將是wxPython(not in Python 3尚未AFAIK)和「本地」Tkinter(這是別的...)。

0

如果PyQt4是您需要的唯一非本地模塊,應該沒有問題。 檢查您需要的所有模塊是否可用於Py3k! PyQt4 Py3k尚未集成到所有發行版中。 也就是說在Debian上PyQt4目前僅適用於Python 2。

看看3to2!將Py3轉換爲Py2代碼的工具。 這比在Py2中編碼和使用2to3更好。

+0

*標準Debian *是什麼意思,考慮到它有3個主要套件(穩定,測試,不穩定)? – Tshepang 2011-08-20 07:19:10

+0

On lenny/oldstable with Python 2.4 and 2.5 關於使用Python 2.5和2.6的squeeze/stable 關於wheezy /使用Python 2.6和2.7測試 使用Python 2.6和2.7在sid/unstable 截至今天i386和amd64。 – phobie 2011-08-25 16:31:41